#87 Estandarizar Dockerfile de prosody

Open
opened 1 year ago by drymer · 4 comments
drymer commented 1 year ago

Deberia:

  • Usarse alpine: (@m0u lo miró hace un tiempo y lua-sec no se empaquetaba, por lo que no era posible)
  • Hacer un script de construcción sin valores hardcodeados.
  • Hacer que escupa los logs a stdout.
  • Hacer que esté demonizado por defecto.
  • Quitar paquetes innecesarios.
  • Dejar claro que version de prosody se usa.
  • Generar certificado ssl al arrancar.
Deberia: - Usarse alpine: (@m0u lo miró hace un tiempo y lua-sec no se empaquetaba, por lo que no era posible) - Hacer un script de construcción sin valores hardcodeados. - Hacer que escupa los logs a stdout. - Hacer que esté demonizado por defecto. - Quitar paquetes innecesarios. - Dejar claro que version de prosody se usa. - Generar certificado ssl al arrancar.
drymer added the
Dificultad: Facil
label 1 year ago
ceighlander commented 1 year ago
Owner

Generar certificado ssl al arrancar.

Buena suerte con los tests

> Generar certificado ssl al arrancar. Buena suerte con los tests
drymer commented 1 year ago
Owner

No hacemos tests de imagenes. Y tampoco veo que sea muy relevante.

No hacemos tests de imagenes. Y tampoco veo que sea muy relevante.
lyz added the
Prioridad: Baja
label 1 year ago
lyz added the
Prioridad: Media
label 1 year ago
lyz removed the
Prioridad: Baja
label 1 year ago
drymer commented 1 year ago
Owner

Estamos pendientes de que lua-sec se meta en el repositorio de alpine. Podriamos ver la opción de compilarlo.

Estamos pendientes de que lua-sec se meta en el repositorio de alpine. Podriamos ver la opción de compilarlo.
rafa commented 1 year ago
Collaborator
Parece que ya está lua-sec. https://pkgs.alpinelinux.org/package/edge/main/x86_64/lua-sec
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Due Date

Jan 01, 0001 Overdue

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.